Jump to content
Althir

Melia quick setup

Recommended Posts

Requirements

Installation

1.  Install Visual Studio & Xampp

2. From Xampp install Apache & Mysql, then start both modules.

c586f8b09c.png

 3. Compile Melia with Visual Studio. Then go to system\conf and edit database.conf & web.conf to match your settings.
If you have password, add it to database.conf. Close Skype if you use port 80. However, I recommend to change this port to 8080.

4. Go to http://locahost/phpmyadmin and from top bar, choose "Import". Choose "main.sql" file from Melia's sql folder and import it.

5. Navigate to Tree of Savior Client folder, then to release folder and look for "Client.xml" file.

6. Edit the following settings (ServerListURL & StaticConfigURL). If you wish to run the server on local machine, just copy following settings. If you want to host it publicly, edit the IPs to match your public IP. Save the settings when done. If you did not change the port from web.conf, change the 8080 to 80.

<GameOption ServerListURL="http://127.0.0.1:8080/toslive/patch/serverlist.xml" StaticConfigURL="http://127.0.0.1:8080/toslive/patch/"

7. Run "Start-all.bat" from Melia folder and start the game from Steam. If you run it from the game folder, it won't run. You should get no Errors.

4e6a162802.png

 

8. Create account by typing new//accountname where "accountname" can be anything. Also type a password that you can remember. Hit login and enjoy!

_________________________________________________________________________________________________

Problem solving!

 

Q: "Login dialog has username & password fields, but lists official servers. What to do?"

A: Change the ServerListURL & StaticConfigURL properly. Make sure that port is same with web.conf one.

Q: "Some parts of my game are in Korean".

A: Change the ServerListURL & StaticConfigURL properly. Make sure that port is same with web.conf one + Delete user.xml & user_c.xml.

Q: "Dialog is missing from buttons and forms."

A: Delete user.xml & user_c.xml.

Edited by Althir
Updated the guide.
  • Like 6

Share this post


Link to post
Share on other sites
4 hours ago, Althir said:

If you run it from the game folder, it won't run.

Actually, I guess I forgot to put that somewhere, you can start the client from the folder, if you call it with the parameter "-SERVICE", with a shortcut or a bat.

4 hours ago, Althir said:

Close Skype.

No need to close Skype if you change the port^^

  • Like 2

Share this post


Link to post
Share on other sites
8 hours ago, PleasureBot said:

Thanks for this.  Any tips of keeping Melia updated?

TortoiseSVN is what I use, it will put a green check mark on the folder if it's updated, if it's not updated you use tortoiseSVN to update it

Share this post


Link to post
Share on other sites
1 hour ago, DR4LUC0N said:

TortoiseSVN is what I use, it will put a green check mark on the folder if it's updated, if it's not updated you use tortoiseSVN to update it

Perfect, thanks!

Share this post


Link to post
Share on other sites
17 hours ago, Cosmos said:

Updated to use the correct port number since it seems to have changed to 80 ;)

What?
 

3 hours ago, boardza said:

It's working for me. Thank you so much

No problem! :)

 



Edited the guide and added new section.

Edited by Althir

Share this post


Link to post
Share on other sites

Step six of your guide had the IP set as 127.0.0.1:8080, but the default port for the melia web server to run on is simply port 80.

I missed the step of your guide explaining people should change the default melia port to port 8080 however, so that was my mistake. I rolled back my edit so it should be back to what you had it listed as. My mistake!

  • Like 1

Share this post


Link to post
Share on other sites

Hello! great guide btw, but i have an issue and idk what i am missing

1. i didn't understand where i need to type the new//accountname thingy, so i did it manually

2. everything works like charm..... but when i try to "log in" it stuck at the login and i cannot enter to the lodge

maybe i am missing something? 

it would be great if you can help me~

Edited by AsunaS

Share this post


Link to post
Share on other sites
Quote

i didn't understand where i need to type the new//accountname thingy, so i did it manually

You're supposed to type it into the login screen in the username field.

As for your second question, can you let us know if you have any red in the Melia console windows? Screenshots can be super helpful

  • Like 1

Share this post


Link to post
Share on other sites
59 minutes ago, Cosmos said:

You're supposed to type it into the login screen in the username field.

As for your second question, can you let us know if you have any red in the Melia console windows? Screenshots can be super helpful

Thanks about the first answer! 

about the second... i figured out that the issue was just related with the first question! now i am playing and works like charm *i am using Linux VPS!* 

some screenies~ 

 

Sin título.png

Share this post


Link to post
Share on other sites
1 hour ago, luiz123o said:

 

guys how do I compile am learning with you here

Open Melia.sln in visual studios, once the solution is fully opened click the "build" button at the top, then hit clean solution, then build

  • Like 1

Share this post


Link to post
Share on other sites

Sorry for not replying, I've been very busy with my life. Thanks for everyone who have helped other people on this topic, you guys rock! :)

33 minutes ago, luiz123o said:

 

thank you man got here put it to work more have a problem NPCs do not respond and also has no mobs on the screen what I do now?

 

Melia does not have NPCs or mobs yet. You can spawn them manually to test them out but nothing works properly yet.

Share this post


Link to post
Share on other sites
4 hours ago, Althir said:

Melia does not have NPCs or mobs yet

Actually we should have dummies for all NPCs, they all say the same thing, but they should be there.

  • Like 1

Share this post


Link to post
Share on other sites
On 02/05/2016 at 1:46 PM, kuza2007 said:

hard to get the packet since the ToS need buy DLC.. sad

game is now free to play since 10th may 2016

Share this post


Link to post
Share on other sites
On Saturday, April 09, 2016 at 2:20 AM, AsunaS said:

Thanks about the first answer! 

about the second... i figured out that the issue was just related with the first question! now i am playing and works like charm *i am using Linux VPS!* 

some screenies~ 

 

Sin título.png

excause me,can you uoload your tos client to mega? i had dl a client ,but i can't login into game at local .the client are all error and will exit by itself.

Share this post


Link to post
Share on other sites
On 2/7/2016 at 8:26 AM, exe19890522 said:

excause me,can you uoload your tos client to mega? i had dl a client ,but i can't login into game at local .the client are all error and will exit by itself.

I'll try to do it, tho i just used the current steam client, can you tell me what error it popped up to you?

Share this post


Link to post
Share on other sites
On Friday, July 08, 2016 at 10:55 PM, AsunaS said:

I'll try to do it, tho i just used the current steam client, can you tell me what error it popped up to you?

no it not give error tips,just exit by itself with out any log.

thanks for your reply

Share this post


Link to post
Share on other sites
On 8/5/2016 at 9:21 AM, bgamez23 said:

anyone have a working client supported by the latest version of melia?

I can't say that I do, but aren't the clients essentially a Target-modified version of the TOSClient.exe?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×